Willkommen im neuen Forum von concrete5.de.
Wenn Sie einen Fehler entdecken oder Schwierigkeiten haben, das Forum zu bedienen, zögern Sie bitte nicht, uns zu kontaktieren: Kontaktseite

Diese Nachricht löschen?
Anhang entfernen?
main.less generiert main.css ? oder.... Antworten
Autor Meldung
Andreas.G 0.png Andreas.G

Ich verzweifel hier noch...

Vo über einem Jahr hab ich das mal schon hinbekommen, den Header bzw. das Layout mit Stylizer7 zu ändern.

 

Beim abspeichern der main.css zeigt mir Stylizer den Pfad:

server.com/application/files/cache/css/cloneamental/main.css

welchen aber ich nicht benutzen kann da es nur der Cache ist.

Die einzige main.css die ich finde ist anscheinend eine andere als gewünscht da beim überschreiben keine Änderung am Header stattfindet.

Die main.less in elemantal/css ist anscheined für die main.css verantwortlich, da es der gleiche inhalt wie im Cache ist.

 

Da ich den Header mit dem Menü eigentlich nur fixieren möchte, bräuchte ich mal einen Gedankenanstoss wie ich das am besten lösen kann.

In der header.less werde ich auch nicht so richtig fündig

 

***

div.ccm-page header {
  background-color: #FFFFFF;
  padding-top: 30px;
  padding-bottom: 30px;
  border-bottom: 1px solid #D9D9D9;
  position: fixed;
  height: 130px;
  width: 100%;
  z-index: 999;

***

 

Danke

Andreas

PS:

Gibt es irgendwo eine Übersicht, welche *.less für was verantwortlich sind bzw. eine Baumstruktur

über den Aufbau des Layouts ?

 

19.10.2018 20:43
admin 0.png admin

So wie ich das sehe nutzt Du cloneamental als Theme!
Dort findest Du die LESS Datei die dafür verantwortlich ist so was in der Art

header {
  background-color: #FFFFFF;
  padding-top: 30px;
  padding-bottom: 30px;
  border-bottom: 1px solid #D9D9D9;
  position: fixed;
  height: 130px;
  width: 100%;
  z-index: 999;
....

Du musst dein Cache löschen nachdem Du Änderungen vorgenommen hast.
 

22.10.2018 07:47
Andreas.G 0.png Andreas.G

Habe es unter build gefunden

 

das müsste die header.less sein, werde ich später mal ausprobieren

 

Danke

23.10.2018 07:01
Andreas.G 0.png Andreas.G

Nachtrag:

Ich schreibe das jetzt unter Design bearbeiten in das Benutzerdefinierte CSS rein.
Scheint gut zu funktionieren.

27.10.2018 19:42
Wombat 0.png Wombat

Hallo Andreas,

 

ja, im "Design"-Tab geht der Style in jedem Falle rein. Du hast dann aber doppeltes CSS geladen, welches sich gegenseitig überschreibt (die Einträge in "Design" sind immer dominant).

Wenn Du die Änderungen in /css/build/header.less einträgst, hat das den Vorteil dass die CSS-Deklarationen nicht doppelt vorkommen und Du kannst es in LESS-Code schreiben, was weniger Zeilen benötigen kann (ja nachdem was Du änderst).

 

Auch Einträge in der main.less werden mitgenommen. Grundsätzlich gilt von der Priorität her:

/css/build -> main.less -> Design Tab

Die Einträge innerhalb des /build-Ordners werden in die main.less rein importiert (siehe oberer Teil der Datei) und mit Eintragungen innerhalb der main.less zusammen als gepackt und in den Cache geladen. Du kannst also beliebig neue CSS-IDs und Klassen anlegen und hier reinpacken.

Änderungen im Design-Tab werden in den Head-Bereich der Seite rein geladen und nicht als externe CSS Datei bereitgestellt. Das kann das Seitenvolumen vergrößern wenn hier viel eingetragen wird. 

Genauso werden Änderungen im Design-Tab z.B. einen Wechsel der Datenbank nicht überleben, wohingegen Änderungen im /css Folder des Themes immer gültig sind, auch wenn Du mit dem gleichen Theme ein neues Projekt startest. 

 

 

30.10.2018 09:50
Andreas.G 0.png Andreas.G

Danke für diese ausführliche Antwort yes

Im Moment habe ich aber das Problem, das Web von meinem heimischen CENTOS-Server ohne Feher online zu stellen.

 

Da fehlen Grafiken, hatte ich zuhause auch schon festgestellt, obwohl in der Datenbank vorhanden...sind aber auf einmal unter Dateien nicht mehr vorhanden, bzw. nur angegraut.

Dann werden auf einmal Umlaute nicht mehr richtig dargestellt...CENTOS OK, Webhoster nicht OK.

Datenbank und Domainname sind beide gleich ( online und hier bei mir )...ändere das mit der host-Datei immer wieder um.

Solche Probleme hatte ich vor dem Update nichtsurprise

Mal in Ruhe nachsehen, was da los ist.

 

30.10.2018 21:14
Andreas.G 0.png Andreas.G

Nachtrag:

Fehler gefunden !

Lokal hatte ich PHP 7.2.9, online war es noch auf 5.6.x eingestellt.

31.10.2018 06:49

Nachricht hinzufügen